Browser Compatibility

Our platform is compatible with browsers such as Firefox, Chrome, Safari, Edge, and Internet Explorer 11 and above.

Note: Internet Explorer versions older than IE 11 will not display the site properly.

Was this article helpful?
4 out of 4 found this helpful